This Forum has been archived

Visit the new Forums
Forums: Index WoWWiki technical CategorySelect

Feature announcement

Moved from WoWWiki talk:Village pump#Select - new feature

In our continued efforts to make editing wikis easier and faster, we have a new feature to announce, called "CategorySelect".

This feature makes it much simpler to add and edit categories from the edit page, whilst also making it possible to add new categories without ever visiting the edit page. We would love to hear your feedback on this new feature - feel free to ping me directly or respond here with any issues.

You can find out more about the new feature at Help:CategorySelect. Kirkburn  talk  contr 00:10, 5 March 2009 (UTC)

It looks like the button to add categories on the article page should be in line with the category text. On my browser (Firefox 3.0.6) it is being displayed under the first category in the list. Not sure if this is browser specific or even if it is intended... --Wige (Talk - Contribs) 19:31, 5 March 2009 (UTC)
Overall I like it, but as mentioned above, the spacing and positioning could use work. Also, if you try to click Save before pressing enter to accept the category name typed in, it doesn't work. Also, it maybe just my settings, but the highlight/text colors make it really hard to see the choices in the dropdown. Lastly, I don't seem to get any drop-down choices after I type the first word, so as soon as I hit space, the choices go away. I'm using FireFox 3.0.6 on WinXP and 3.0.7 (I think) on Mac OS X 10.4.x. --Gengar orange 22x22 Fandyllic (talk · contr) 4:59 PM PST 5 Mar 2009
I started a Help:CategorySelect page where I'm dumping what I've experienced. Right now Help:CategorySelect doesn't have alot of info, so I'm focusing on a local WoWWiki help page for now. Maybe the local one will have nfo migrate over at some point. --Gengar orange 22x22 Fandyllic (talk · contr) 5:25 PM PST 5 Mar 2009
I tried using this new feature but it does not work for me. I still have to manually add or remove categories for some reason. Rolandius Paladin (talk - contr) 03:59, 6 March 2009 (UTC)
Hmm, it doesn't appear for me. User:Coobra/Sig3 04:36, 6 March 2009 (UTC)
What skin are you using. As with many things at Wikia, it probably only works with Monaco-based skins. --Gengar orange 22x22 Fandyllic (talk · contr) 12:18 PM PST 6 Mar 2009
I was using the wowwiki skin, so I checked the box for Check this box to use the custom WoWWiki Monaco skin (recommended) and it works... I'll try it out, maybe it will make things faster, if not... well, we'll see. Thanks. User:Coobra/Sig3 22:27, 6 March 2009 (UTC)
To be frank, I never quite got the point of the categories. Yes, I understand obsessively compulsively organizing things... but the category index pages are just... useless. In all my years here I've *never* felt myself needing to use them. Someone enlighten me? TeжubԎ Ҩ Ѡ 19:46, 6 March 2009 (UTC)
I just recently used a category to find a bunch of other icons, since searching for images on the wiki is kind of weak. --Gengar orange 22x22 Fandyllic (talk · contr) 7:46 PM PST 7 Mar 2009
Well I use them frequently. Perhaps it's just not necessary for everyone. It's not available for the wowwiki skin and I really don't want it. I just don't like JavaScript gimmicks.--Iggey (talk) 20:43, 6 March 2009 (UTC)

Just a quick note, we're working on making it a user option. Thanks for the feedback! Kirkburn  talk  contr 18:10, 9 March 2009 (UTC)

Some quick notes on my own experience with this feature:

  • A number of page boilerplates (achievements and quests, to name the ones I've run across) use the sidebar template to add categories to a page. The new feature does not help on that.
  • much of the feature is disabled when javascript is not enabled. (I use firefox 3.0.6 with NoScript addon, and run with javascript disallowed by default.)
  • Enabling javascript (from wowwiki and wikia both) produced (among other things) a "see this new feature" box that took up space at the lower left hand corner of the edit box, making it problematic to edit text underneath it. No obvious means of getting rid of it was present.
  • no Preferences option was available to enable/disable it. (So I disabled it by turning javascript off again.)
  • it seemed to remove the category listing at the bottom of the page when performing a preview, even though the tooltip (er, achievementbox) template specified one. I was unable to see in preview that the category I first specified was bogus. Happened both on creating a new page and on editing an existing page, and with javascript disabled.

Hope this feedback is useful. --Eirik Ratcatcher (talk) 19:30, 11 March 2009 (UTC)

More notes from the field:
  • You can't turn this feature completely off currently. Adding a category manually gets it put down in the 'category display text box' below the edit box. With Javascript turned off, the categories disappear and cannot be made visible.
  • the "add categories" button is visible when javascript is turned off. But it is inoperable.
  • The 'code view'/'visual view' selector is not visible with javascript turned off. A useful default would be for the page to use the 'code view', as I was unable to get visual view to allow me to edit an existing category (despite going to the help page for ... help). A more useful default would be the old functionality (one text box, everything in it), as that does not rely on javascript at all. It would also be nice to have 'code view/visual view' have a preference checkbox.
  • Because the contents are not all in one text box, the new functionality precludes being able to cut-and-paste categories in the same action as cutting-and-pasting the rest of the article. (Two cuts needed, AND javascript must be enabled, currently.)
--Eirik Ratcatcher (talk) 22:38, 11 March 2009 (UTC)
Update: this morning, default behavior for "no javascript enabled" was a category box below the edit box, with category text in it. Categories still not displayed on preview. Improved over yesterday; previously box was either missing or mis-sized and so not useable in 'no javascript' mode. Appreciated. --Eirik Ratcatcher (talk) 17:57, 12 March 2009 (UTC)

Category bumout

Moved from WoWWiki talk:Village pump#Category bumout

Any reason why it seems impossible to change article categories with the new box? --User:Varghedin/Sig 10:39, 12 March 2009 (UTC)

Thats how it was implemented by Wikia. -- Wige (Talk - Contribs) 13:59, 12 March 2009 (UTC)
Hmm, it shouldn't be impossible? What issue are you seeing? Kirkburn  talk  contr 20:05, 13 March 2009 (UTC)

Editing problem

Moved from WoWWiki talk:Village pump#Editing problem

Whenever I edit an article using either Visual View or Code View, the line space between the Category section and for instance the Reference section is removed. Any ideas? Rolandius Paladin (talk - contr) 03:46, 24 March 2009 (UTC)

In this particular case the Code View / Visual View is just only for Categories - you do not touch that unless you are adding / removing / modifying a category:
  • In the Visual view mode you click on the Add category floating on the left side of the screen - in the right most category location - otherwise you click on the + or x of an existing category to modify or remove (respectivly).
  • Correction I said you use the + or x to modify or remove -- I meant the Arrows or the X to modify or remove -- (M o r p h | C | T) IconSmall Gnome MaleIconSmall Draenei Male 04:09, 24 March 2009 (UTC)
  • In Code view you manualy enter / edit / remove the cateogries like we used to do it on the main page you type everything out [[Category:Borean Tundra NPCs]] or [[Category:Borean Tundra NPCs|Borean Tundra]].
If edditing page content - do not mess with visual / code view area at all

-- (M o r p h | C | T) IconSmall Gnome MaleIconSmall Draenei Male 04:03, 24 March 2009 (UTC)

Well essentially, I could be editing something way on top of the article, like bolding the title, and when I then hit Preview or Save, somehow it still affects the categories it seems without me touching anything near the categories. At least, that is what other users are saying whenever I edit an article. On my computer, it looks like there is a space still but then other users have to edit an extra space into the article they say. Rolandius Paladin (talk - contr) 04:17, 24 March 2009 (UTC)
I know when they 1st implemented the new category thing there was a problem with extra spaces being added in - and Kirkburn said that Wikia was working on it - could it be they over did it and now it is removing more spaces than needed ? -- but then if that were the case it would be affection all of us hmm - Which browser are you using ( and version ) I am using the new IE 8 ( I was on IE 8 RC ) and have found a few problems with it so far - but have not been told that I am adding or removing spaces if it is the cause of your problem if you are on IE 8 -- (M o r p h | C | T) IconSmall Gnome MaleIconSmall Draenei Male 04:24, 24 March 2009 (UTC)
I have Safari 3.2.1. Rolandius Paladin (talk - contr) 05:00, 24 March 2009 (UTC)
hmm ok I loged in on Safari 3.2.1. as well and looked at one of the last few pages you had edited Zhevra Runner if you click on the History tab and then click the (Last) that is next to your name you can see what changes were done by you per the server [Link] to same info as well - you can see on the left there was a line between the 2 lines of info - shown in red meaning it was (for some reason) removed - I went in ( using Safari 3.2.1.) and added and then removed a line to see how what it did - for me it did what it was supposed to aded the 1 line and then removed the 1 line - so at the moment I am at a loss as to what is causing the problem -- (M o r p h | C | T) IconSmall Gnome MaleIconSmall Draenei Male 05:44, 24 March 2009 (UTC)
ooh yeah before I added / removed the line I did click on edit and did not make a change but clicked on Preview and then save - and it did not make any changes to the page untill I added and then removed the line mentioned above - so again I am at a loss as to what is going on -- could you maybe be removing the extra spaces at the ENd of the line ( and accidently going 1 space into the next line - thus causing it to remove the whole line - not realizing it ? -- (M o r p h | C | T) IconSmall Gnome MaleIconSmall Draenei Male 05:44, 24 March 2009 (UTC)
I am not sure what it occuring. It happens when I don't even touch the bottom of the article. I thought I could use a < br > to force a space but someone told me not to. I guess I will do some trial and error in my subpages to see if there is a way to figure it out. Rolandius Paladin (talk - contr) 05:50, 24 March 2009 (UTC)
I think I figured it out trying different methods. It looks like when I edit a page, sometimes I have to go to the Category box and make 2 line spaces for it to recognize one line space or something. Rolandius Paladin (talk - contr) 10:39, 24 March 2009 (UTC)

Ad blocker interference detected!

Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.